SUMMARY
The appliance may generate misleading alerts regarding volume changes.
ISSUE
The appliance may generate misleading alerts regarding volume changes. These alerts may suggest that backup schedules need to be updated.
Example output of error that may be related to this condition. :
Volumes on <client> have changed from C: UnmountedVol:/{UUID} to C: Ok UnmountedVol:/{UUID}. File-level schedules for this client should be updated.
RESOLUTION
Note the volume list returned in output above will be the same list of volumes and UUID will match for those volumes, but there is an inserted "ok" as part of the output after the drive letter before a volume ID. This confirms you have this issue.
To resolve this issue, upgrade your appliance to version 10.1.
CAUSE
A race condition was discovered when windows delays results returned from volume scans which could result in an unexpected return response. During nightly system checks, the system was not properly handling garbled return results in rare cases when this occurs which would produce an erroneous error. Re-saving the client in the assets UI would resolve. Checks have been added to prevent incorrect responses from being processed.
This is a rare case believed to be related to a windows environmental issue, but no root cause is able to be determined as to why Microsoft occasionally delays responses to volume scans. Even when delayed in most cases the results are normally returned, but in a rare case a response code is not properly formatted.