FAQ: Backup failures due to network connection stopped

SUMMARY

This article discusses how to provide a solution to backup failures due to some network connection issues

ISSUE

Purpose

Provide solution to backup failures due to network connection issues in some cases

Applies To

Windows Agent based Backups

Symptoms / Description

Backups fail due to network connection stopped or WinSock error 10054

Cause

An existing connection was forcibly closed by the remote host. This normally results if the peer application on the remote host is suddenly stopped, the host is rebooted, the host or remote network interface is disabled, or the remote host uses a hard close (see setsockopt for more information on the SO_LINGER option on the remote socket). This error may also result if a connection was broken due to keep-alive activity detecting a failure while one or more operations are in progress. Operations that were in progress fail with WSAENETRESET.  Subsequent operations fail with WSAECONNRESET.

Resolution / Workaround / Execution Process

Add or update the following TCP/IP tuning parameter in the Windows registry and then reboot and try a new backup attempt.

 

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Tcpip\Parameters]

TCPMaxDataRetransmissions=dword:00000010

 

Third-Party Sources

https://docs.microsoft.com/en-us/previous-versions/windows/it-pro/windows-server-2003/cc780586(v=ws.10)

https://docs.microsoft.com/en-us/previous-versions/windows/it-pro/windows-2000-server/cc938210(v=technet.10)

https://support.microsoft.com/en-us/help/170359/how-to-modify-the-tcp-ip-maximum-retransmission-time-out

 

Have more questions?

Contact us

Was this article helpful?
0 out of 0 found this helpful

Provide feedback for the Documentation team!

Browse this section