Windows agent file-level backup failure due to change journal wrap or Journal range exceeded

SUMMARY

How to fix backup failures due to change journal wrap errors

ISSUE

 

Unitrends' agent for Windows uses each volume's NTFS USN change journal to determine which files have been modified since the prior full or incremental backup's point-in-time.  If the USN change journal for the volume in question does not contain the point-in-time of the prior successful backup then we cannot trust the journal to contain information for all of the file system's changes since that backup, and we fail the backup attempt.


Sample error message:
 
----- Error Messages -----
The first record available for reading from the Change Journal for volume 'C:/' is higher then agent backup in previous backup and indicate there is a chance that file or directory changes will be not backed up. Please take a new master backup to correct a problem.
Change Journal for volume C:/ appears to have wrapped.
Refer to the Unitrends Agents manual for instructions on enlarging the Change Journal size.
Volume 'C:/' (//?/VOLUME{72F45FDD-3A8D-11E7-80B4-806E6F6E6963}/): The USN Journal was not registered because it experienced a wrap condition.
Backup job was terminated due Change Journal registration errors. Please correct the problem and perform a new full backup.
Windows Instant Recovery is not possible for this backup.
----- End Error Messages -----

RESOLUTION

Basic resolution:

Unitrends has made Windows agent changes to help prevent this from occurring.  Please upgrade to the latest agent release and then run a new, successful full backup of the protected asset(s) in question


You may download the latest Windows agent from https://support.unitrends.com/UnitrendsBackup/s/downloads.

Advanced resolution:

To address the USN change journal is too small issue, follow the steps below:

1. Connect to the System being backed up and open a cmd admin 
2. Check current journal size (note the Maximum Size) (using C: in this example, you may have different or additional volumes where a journal wrap has occurred):


fsutil usn queryjournal C:


3. Open Calculator in programmer mode. Then select the Hex radio option.
4. Paste in the Maximum Size value from step 2 above. Then change the radio to the decimal option.
5. Divide by 1024 twice to convert the units to Megabytes.
6. add 2048 to this number.
7. multiply by 1024 twice to convert back to bytes.  
8. use this value to in place of the red numbers below the command below.  

 

fsutil usn createjournal m=4294967296 a=1 C:
 


8. Run a new, successful full backup of the client(s) in question.

 

WARNINGS:  USN Journal size should not be more than 50% of system RAM.  Additionally, USN journal must fit comfortably in available system free space (minimum 10% free is strongly recommended AFTER adding 2GB to the journal size).  Only change the journal to more than 4GB on a volume that has wrapped, do NOT apply large journals to all volumes using the client master.ini!  

 


Should the problem continue:


1. You can increase your backup frequency to daily or more frequently, depending on change rate.
2. Yan can increase the journal in 2GB increments (or more if you believe it;s needed) up to a max 2TB journal size in 64bit systems (4GB is the max for 32bit systems and all editions windows 2003). 
3. You can export the journal to CSV following the KB Advanced Change Journal Wrap Review and try to help the customer ID what files are causing the repetitive change.
4. where supported switch to image backups which do not leverage the journal.  

CAUSE

The root cause is one of two things, or both:

1. The USN change journal is too small
2. The backup frequency is too infrequent

NOTES

​Note:  For advanced administrators, you may chose to set the change journal to a different size using this command.

References  

https://docs.microsoft.com/en-us/previous-versions/windows/it-pro/windows-server-2012-R2-and-2012/cc788042(v=ws.11)
 

Have more questions?

Contact us

Was this article helpful?
0 out of 0 found this helpful

Provide feedback for the Documentation team!

Browse this section