USNAP is not able to create a volume shadow copy

SUMMARY

Agent-based backup fails with "Usnap is not able to create a volume shadow copy"

ISSUE

Windows agent-based backups fail with "Usnap is not able to create a volume shadow copy" error.

    RESOLUTION

    Please use this KB when addressing this issue, please note that this process gives the server more time to complete VSS operations and may not resolve the underlying problem.  When encountering VSS errors in backups it is always helpful to look for errors in VSS operations in Windows Event Viewer.

    To resolve USNAP volume shadow copy failure on Windows clients, on the client server having the backup errors:

    1. Open C:/PCBP/MASTER.ini in a text editor, as an administrator.
    2. Find the [usnap] section and increase the following values by 600 (be sure to add 600 to the existing value): 
      USnapEnable=TRUE
      USnapKeepalive=1800         ; increased value by 600 
      USnapMutexTimeout=1420      ; increased value by 600
      USnapVssAsyncFinished=1200  ; increased value by 600
      USnapProvider=System        ; add if there are multiple VSS Providers
      
    3. Save the MASTER.ini file.
    4. Restart the "bpagent" service. This will ensure the changes are registered and applied.

    CAUSE

    USNAP timeout condition occurs before snapshot completes.

    NOTES

    For more detailed information on backup failures and performance issues see Unitrends KB 5062 - Backup Failures and Performance Issues

    Have more questions?

    Contact us

    Was this article helpful?
    0 out of 0 found this helpful

    Provide feedback for the Documentation team!

    Browse this section