Hyper-V CBT error CBTDriverError:uvbCbtSnapshotCreationStarted

SUMMARY

CBT drive on a Hyper-V cluster can get out of sync.  This can cause CBT issues with getting changed blocks resulting in incremental backups that are the same size of a full backup.

ISSUE

----- Error Messages -----
CBTDriverError:uvbCbtSnapshotCreationStarted:: FFFFFFFF80070002
Due to previous error, Unitrends agent is not able to use the Hyper-V CBT filter driver during backup job for VM {A4C9989D-86C9-4769-81FE-E8765E5B6691}: all files will be backed up as full not change blocks.
----- End Error Messages -----

RESOLUTION

Open the following file in notepad and review the Sync Status line on each Hyper-V node in the cluster.

C:\unicbt\config\in.xml

You will see if the drive is InSync or NoSync or OutSync like the following.

<CBT>
  <VERSION>2</VERSION>
  <SYNC_STATUS>NoSync</SYNC_STATUS>

If the driver is out of sync you will want to stop the CBT (UnitrendSVC) service on each Hyper-V node.

User-added image

Once the UnitrendSVC service is stopped on each node, start the UnitrendSVC on each node to complete the sync CBT.  

User-added image

Lastly, take another Hyper-V full backup which, once completed, should remedy the incremental backup size issues moving forward.

If the issue persists, rip and replace of the driver across all Hyper-V nodes before reinstallation may be necessary.

The steps for removing/reinstalling the agent and CBT driver when having CBT issues are as follows:

  1. Copy C:\PCBP\keystore somewhere for safe keeping.
  2. Stop the BP_Agent service
  3. Uninstall the current Unitrends agent
  4. Verify that C:\unicbt does not exist, if it does exist run as admin-> C:\PCBP\Win2012.dir\<CBT Driver Directory>\uninstall.bat  (IE: C:\PCBP\Win2012.dir\07-28-2020,10.4.8.0\uninstall.bat
  5. If following the above mentioned has been ran and the C:\unicbt directory still exists, you may need to reboot the host and re-run the uninstall script as mentioned above.
  6. Once the C:\unicbt directory is gone, remove the PCBP directory entirely (backup keystore! step #1)
  7. For Hyper-V clusters, perform the above mentioned on all nodes before continuing.
  8. Run the latest agent installer
  9. Copy keystore contents back to C:\PCBP\keystore to ensure SAP continues to work.

 

CAUSE

CBT drive loses sync with the other cluster nodes which requires a reset to get the driver back in sync.

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