SUMMARY
Snapshot appear orphaned on the datastore, consolidation may be required. VMDK are left on the Unitrends virtual appliance.
ISSUE
VMWare disk consolidation needed
RESOLUTION
When you have a "VMware disk consolidation needed", you need to check the following:
- On the Unitrends Backup Guest VM, edit the VM and look at the virtual disks attached (and their paths). If you see any foreign disks, verify that there are no backups associated with those disks, then detach them. It is not normal for the Hypervisor to leave them behind after we have issued the command via APIs to drop the disks (see #7 below). In many cases, after detaching the disks, the Hypervisor will perform the proper disk removal and consolidation. Please proceed to #2 if you do not see this occur.
- For the Guest VM with the issue, check the Snapshot Manager and see if the Hypervisor recorded a snapshot taken, and when it was taken.
- In VMware, for the Guest VM with the issue, edit the VM and look for virtual disks with a name that has many 00000#,vmdk, this is a snapshot. Unitrends can not backup a VM with a snapshot because of how the Hypervisor manages the delta. Record the path to the current disk listed for your records.
- in VMware, view the Datastore for the disk (you will see it in the path. A quick way to get to the data store is to use the Summary page for the Guest VM, right click on the datastore and select "Browse". Check that the directory for this Guest VM does not contain other snapshots (VMDK files that have the 00000#). Document the disks you see that have the 000000# in the name.
- In VMware, use the Snapshot Manager to "Delete All". This process will also consolidate at the same time. If you do not see a snapshot listed in the Snapshot Manager, but did see a Snapshot in the Datastore, create a new Snapshot, then perform the "Delete All".
- Once the removal of the snapshot and consolidation has completed, verify the Guest VM is on the non-snapshot disk (the original) and that there are no more snapshots in the datastore. If this is not true, you need to contact VMware for help. They are the only ones that can look through the logs and determine if the left over snapshots can be deleted without penalty.
- Check with the Hypervisor manufacture and ensure that your Hypervisor is on the most current release for the major version it is on. VMware (for example) has documented issues with snapshots and Change Block Tracking which were resolved in product updates. Because Unitrends uses the Hypervisor's latest APIs, this is a step that must be done to ensure the accuracy of your backups.
- It may be necessary to clean hung jobs from the UI by following Cancelled jobs hung in the UI.
- Run a 1-Time Full of the affected VMs to ensure we have the full virtual disk data and to set Change Block Tracking to this point in time for accurate future backups.
For more information about the Delete All process, view VMware KB 1023657 and for understanding VM snapshots in ESXi, view VMware KB 1015180.
CAUSE
This occurs when communication can not be conducted between vCenter/Host/Datastore and the Unitrends System.