SUMMARY
When adding a SQL Server client, the appliance may detect the presence of a SQL instance but not be able to list active databases.
ISSUE
The Unitrends UI lists a SQL instance present on a windows client containing an agent for backup, but when expand, the server, it shows no databases.
RESOLUTION
A common issue is the Microsoft SQL VSS service is not running on the windows machine, and the resolution is to start it. You may find the Microsoft Service management page to start the SQL VSS Writer and set to Automatic.
1) Start the Services Microsoft Management Console (services.msc)
2) Click on SQL Server VSS Writer.
3) Click Start to start the writer. Ensure the Startup Type has changed to Automatic.
4) On the Unitrends system click on the symbol (top right) and select INVENTORY SYNC.
If this does not resolve your issue, also confirm proper permissions for NT Authority/System are present in your SQL instance. See this article to correct/update SQL permissions: This process is required on SQL 2008+ instances.
CAUSE
The Microsoft SQL VSS Writer must be in started and stable condition for us to be able to read the database on the SQL Server. For more information, please see Page 302 of the Administrator Guide for Recovery Series and Unitrends Backup Release 10.0 | July 2017 (PDF version)
"The SQL Server VSS Writer, SQL Server Browser, and BP Agent services must be installed and running to perform backup and restore operations. If the SQL Server VSS Writer or SQL Server Browser services are not started when you install the Windows agent, the agent cannot detect the SQL instance."