Clearing stale or orphaned Microsoft VSS snapshots

SUMMARY

This article provide steps for clearing stale or orphaned Microsoft VSS snapshots

ISSUE

Snapshots are failing due to a space constraint on the protected asset.  This may be a result of stale or orphaned snapshots, often created by 3rd party programs, failed windows updates, or general errors with the Windows VSS services itself.  To free disk space for further backups to properly operate these old stale snapshots need to be removed. .

You may discover this issue when reviewing a failed backup summary report by noting the following highlighted sections below.  This issue may be more common on SQL servers as they commonly run multiple concurrent snapshots at once, but can occur on any windows system.  
 

----- End Summary Messages -----
----- Error Messages -----
The Unitrends agent aborted Microsoft SQL Server backup, because agent failed to complete a volume shadow copy operation (create a snapshot). Please review Windows System and Application Event Logs for more information. ****> ERROR: 1 File not backed up. For more information, review backup catalog file.
----- End Error Messages -----
----- Client Messages -----
2% free space (234.00 MB of 16.07 GB) is available on volume \\?\Volume{xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxx}\.
The database SQL DB, instance SQL Instance is online.
VSS Application Volume list build successfully.
----- End Client Messages -----
----- Files Messages -----
Microsoft SQL Server BP: application backup list error.
----- End Files Messages -----


 

RESOLUTION

 

Open an administrative command shell (run cmd as administrator).

use vssadmin to delete all shadows using the following command.  WARNING: Do not run this command if the server or workstation is pending a reboot to install Windows updates!

C:\>vssadmin delete shadows /all

 

In some cases this may not complete or fail. In that case, check for VSS errors.  If you receive errors for one writer, you may need to fix that particular service . It is quite common to receive multiple errors from several related services, such as “VolSnap” and “Disk”.
 

C:\>vssadmin list shadows

 

If you see a VSS error with the above command, try the following:

Restart the services:

COM+ System Application
Service, Distributed Transaction Coordinator Service, and Volume
Shadow Copy Service


*Edit* 7-27-16
########################################
Check services for any abnormal state. 

Example 

Virtual Disk Service is stuck in a "Stopping" state, the process may need to be manually stopped and restarted.

########################################

 

It may also be necessary to restart the affected service, for example, the Hyper-V VSS writer, or entirely restart the server.  

The most important thing to do is to check the Event Viewer for any additional error information logged. Usually each VSS aware service will have its own logs, most likely inside the Event Viewer.

CAUSE

VSS shadows are a fundamental requirement to protect modern windows systems to access files otherwise locked by the OS or applications during runtime.  This is a Microsoft provided service.  For dozens of reasons this service may not be functioning properly preventing the creation, or in this case removal, of snapshots for the windows disks.  Such issues are considered critical issues, and in many cases indicate serious system corruption or program errors.  

Unitrends is unable to directly troubleshoot VSS errors with customers as the VSS subsystems are a black box we only request processes from.  All VSS code and troubleshooting processes are reserved to Microsoft itself.  Thankfully, most VSS errors do produce Microsoft-specific HREF or 0X0 error code formats which can e reviewed online or provided to Microsoft Support for further analysis.  Where VSS errors continue to persist after reboot and program errors cannot be corrected easily by windows update or available Microsoft hotfix, redeployment of a clean server and migration of data, or, recovery of a prior version of the OS from backup may be required to resolve.  Additional troubleshooting processes for VSS are linked in the below article. 

Unitrends does not cause VSS errors, VSS is instead required to be otherwise functioning for backup products from unitrends and other vendors to function.  

NOTES

Additional common VSS troubleshooting steps are discussed in Volume Shadow Copy Service Errors.  (These steps are taken from Repair Strategy #2 of 11).

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