AD Deployment-based Agents not updating properly since upgrading to a newer VSA version

  • SYMPTOM 
    AD Deployment-based Agents not updating properly since upgrading to a newer VSA version.

    There are now two Agents viewable for one machine. It is unknown how this occurred.

 

  • CAUSE 
    The currently applied AD-based KAgentDeployment policy is an older-based policy w/ older Windows Agent installation file components.

    On the Domain Controller-based machine, visit the Group Policy Manager and check for existence of a group policy called "KAgentDeployment". If this is present (one or more), then this is evidence that this is the cause of the issue.

    Also, one can download the much easier to use Group Policy Management Console (GPMC) SP1 app onto the Domain Controller-based machine and use this to find this policy. The download for this is here:

    http://www.microsoft.com/downloads/details.aspx?FamilyID=0A6D4C24-8CBD-4B35-9272-DD3CBFC81887&displaylang=en

 

  • RESOLUTION 

    One will need to recreate the Deployment policy on the Domain Controller used with the not-updating agents that are associated with AD Deployment policies (Users or Machines), delete them & recreate them so that the K2 v6 Agent package installer is used in this situation. If it is not needed, then simply delete this policy on the Domain Controller.

    From there, for these symptom machines that are not updating, the following has to occur:

    1) Using a non-Kaseya remote method, uninstall both Agents present on the machine (you will see that there are two listings in the Add/Remove Programs listings).
    2) Reboot the machine.
    3) Reinstall the Agent w/ an appropriate updated Win package or with a latest version-based KAgentDeployment Logon policy or Machine policy (as described above) if you are updating the Domain Controller for these machines with this policy.
    4) In the Agent > Install Agents > Rename page, merge the previous problematic offline agents with the properly reinstalled online agent.


    For multiple accounts appearing, the following can be taken to resolve this:

    1) If one agent is exhibiting problems, uninstall that one or whichever one is preferred to be uninstalled. 
    2) In the Agent > Install Agents > Rename page, merge this now offline agent with the other still online working agent.

 

  • APPLIES TO 
    AD / Active Directory
    Kaseya Windows Agents

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