Discovery deployment error for MAC: Target refused login. Is remote login enabled?

PROBLEM:

Discovery deployment on Mac machine fails with following error: Target refused login. Is remote login enabled?

CAUSE:

You are getting this error because remote logging is disabled on the Mac.

What is remote logging?

Remote Login is a feature in Mac OS X’s Sharing preferences that allow remote users to connect to a Mac in a secure fashion by using the OpenSSH protocols. Essentially, it starts an SSH server on a Mac, which includes the ability to accept incoming SSH connections, which is the secure replacement for telnet. Additionally, it includes and enables the SFTP server, which is the secure replacement for FTP, and finally, it also enables SCP, for secure remote copying.

 RESOLUTION:

You need to enable Remote Logging on your Mac

  1. Open Sharing preferences if it isn’t already open (choose Apple menu > System Preferences, then click Sharing), then select the Remote Management check box.

Do one of the following:

    • Select “All users” to let all users on your network connect to your Mac using Apple Remote Desktop.
    • Select “Only these users,” click Add, then select the users who can share your Mac using Apple Remote Desktop.
  1. Click Options, then select the tasks remote users are permitted to perform.
  2. Click Computer Settings, then select options for your Mac. If people connect using a VNC viewer, you need to set a password.

 

1.JPG

 

 

 

 

Attachments

Have more questions?

Contact us

Was this article helpful?
0 out of 0 found this helpful

Provide feedback for the Documentation team!

Browse this section