Replication jobs do not show in Job Manager

ISSUE

No Backup Copy Hot jobs are visible in the UI.

RESOLUTION

This issue is resolved in release v.10.4.3. Upgrade to 10.4.3 to prevent this issue from occuring.

Determine if this issue is impacting your system by running this command:

 
psql -c "select * from bp.replication_joborders where replication_joborder_id not in (select distinct replication_joborder_id from bp.replication_joborders_instance_assoc)"


To fix affected jobs, and have Backup Copy Hot jobs show back up in the UI, the affected jobs must be removed from the appliance database. This can be done by running the following SQL query from the command-line of the appliance:

 
psql -c "DELETE FROM bp.replication_joborders WHERE replication_joborder_id NOT IN (SELECT DISTINCT replication_joborder_id FROM bp.replication_joborders_instance_assoc)"


 

CAUSE

When FanOut was introduced in version 10.4.0 there were a lot of configuration changes made in the database to allow having multiple targets. One of these accommodations was in how Backup Copy Hot jobs were stored. Previously, assets would be assigned to jobs but since a source could only add one target the job did not have to keep track of the target as well. Now, jobs are tasked with keeping track of assets and targets. Due to the nature of how these relations are stored in the database it is possible for a job to get in a state where it has no assigned assets anymore. The way this happens is when an asset is removed from the source while being the only asset in that job. If this happens then no Backup Copy Hot jobs are shown in the UI. A fix was added in version 10.4.3 to prevent the ability to remove an asset from an appliance if it is the last asset in a Backup Copy Hot job but it will not fix any current jobs that are already in the affected state.

Have more questions?

Contact us

Was this article helpful?
0 out of 0 found this helpful

Provide feedback for the Documentation team!

Browse this section