SUMMARY
Cannot use Kroll to restore mail to mailbox that is in disconnected state. This article provides resources for connecting to a disconnected exchange mailbox.
ISSUE
Purpose
This topic explains how to use the Exchange Management Console or the Exchange Management Shell to connect a disconnected mailbox. A disconnected mailbox is a mailbox object in the Microsoft Exchange store that is not associated with an Active Directory directory service user account.
Scenarios in which you may want to connect a mailbox include the following:
- You disabled a mailbox and now want to reconnect the mailbox to the Active Directory user account.
- You removed a mailbox by using the Remove-Mailbox cmdlet without the Permanent or StoreMailboxIdentity parameters and now want to reconnect the mailbox to a different Active Directory user account.
- You want to link a mailbox object to an external user account. The resource forest scenario is an example of when you would want to associate a mailbox with an external account. In a resource forest scenario, user objects in the Exchange forest have mailboxes, but the user objects are disabled for logon. You must associate these mailbox objects in the Exchange forest with enabled user objects in the external accounts forest.
Applies To
For Exchange Server 2007, refer to this article: How to Connect a Mailbox
For Exchange Server 2010, refer to this article: Connect or Restore a Disabled Mailbox
For Exchange server 2013, refer to this article: Connect a disabled mailbox
Symptoms / Description
Cannot use Kroll to restore mail to mailbox that is in disconnected state
Cause
Mailbox user was deleted from Active Directory
Third-Party Sources
Exchange Server 2007 https://docs.microsoft.com/en-us/previous-versions/office/exchange-server-2007/bb201701(v=exchg.80)
Exchange Server 2010 https://docs.microsoft.com/en-us/previous-versions/office/exchange-server-2010/bb123490(v=exchg.141)
Exchange Server 2013 https://docs.microsoft.com/en-us/exchange/connect-a-disabled-mailbox-exchange-2013-help