Locked bpd local port can cause BPAgent service not start up after agent push upgrade

SUMMARY

Locked bpd local port can cause BPAgent service not start up after agent push upgrade

ISSUE

Purpose

How to clean up a hung bcp port on a Windows client without rebooting.

Description

A locked bpd port can cause the BPAgent service to not start.

Cause

Backup jobs are running on the client during an agent push upgrade.

Resolution

  1. Cancel all backup jobs for the client.
  2. Stop the BPAgent Sevice.
  3. Install TCPView from Sysinternals (www.sysinternals.com).
  4. Use Sysinternal to start TCPView and close all TCP connections for the wbps process. Find all [System Processes] where remote address is the backup system IP and are in state CLOSE_WAIT or TIME_WAIT. End each of these processes using a TCPView menu.
  5. Start the BPAgent Service
 

Third-Party Sources

TCPView help

Sysinternals - www.sysinternals.com

Have more questions?

Contact us

Was this article helpful?
0 out of 0 found this helpful

Provide feedback for the Documentation team!

Browse this section