Exchange 2003 backups failing with VSS issues

SUMMARY

Resolve issues with VSS errors on an Exchange server

ISSUE

Backups fail with errors pointing to VSS issues, and running the command ‘vssadmin list writers’ on your Exchange server lists your Exchange VSS writer as being in a failed state.

 

RESOLUTION

First, make sure no backup agents other than the Unitrends agent are installed on your server. If you’re using Server 2003, apply the hotfix listed in the “Third-Party Sources” section at the bottom of this article. Finally, re-register the .dll files by opening an elevated command prompt and running the following commands:

Cd %systemvolume%\system32
regsvr32.exe /i eventcls.dll
regsvr32.exe /i swprv.dll
regsvr32.exe vssui.dll
regsvr32.exe vss_ps.dll
regsvr32.exe msxml.dll
regsvr32.exe msxml2.dll
regsvr32.exe msxml3.dll
regsvr32.exe ole32.dll
regsvr32.exe oleaut32.dll
regsvr32.exe es.dll
regsvr32 stdprov.dll
Vssvc /Register

 

Then reboot your server.

 

Third-Party Sources

Server 2003 hotfix: http://support.microsoft.com/default.aspx?scid=kb;en-us;891957

CAUSE

This issue can have a number of root causes relating to the Exchange VSS writer on your server.

NOTES

For more detailed information on backup failures and performance issues see Unitrends KB 5062 - Backup Failures and Performance Issues.

Have more questions?

Contact us

Was this article helpful?
0 out of 0 found this helpful

Provide feedback for the Documentation team!

Browse this section