System State Backup Fails due to VSS when USB drives are attached to server

SUMMARY

Discusses how Hybrid 4K/512byte drive support can affect backups.

ISSUE

Windows backups fail or are marked as incomplete and the logs indicate that a System State Backup could not be completed, but the system state was not excluded from backups.  When looking at the Windows Application event logs errors indicate that VSS entered a retryable state.  A large capacity USB or other external drive is also mounted on the server and a sysvol folder may be present on that volume.

RESOLUTION

In order to perform backups of these systems, the device supporting Hybrid Large BlockAaddressing schemes must be removed.  It is possible to get incomplete backups of these systems where VSS is not used, but backups of domain controllers and most database servers will not be possible in this condition.  Hot Bare Metal backups may also not be possible.  Remove or replace the device that supports large block addressing natively in the hardware.  Microsoft has limited support for 512e devices and VSS does not properly support them.

Third-Party Sources

See Known Compatibility issues in this MS KB:

http://support.microsoft.com/kb/2510009

CAUSE

Most currently sold USB devices over 1TB, and nearly all drives larger than 2TB and some eSATA devices make use of a hybrid Large Block Addressing scheme (also called Advanced 4K or 512e drives) where the drive controller is designed to support drives over 2TB (though the drive itself may not be that large), and supports 4K blocks, but the drive itself supports only 512byte blocks (or vice versa).  This method of block addressing is incompatible with all currently supported versions of windows where block-level access to the disk is required.  Because VSS is a block technology, it cannot take a snapshot of any volumes that utilize hybrid block architecture or synthetic 4K blocks. Windows only supports native 512byte and 4k block devices. In some rare cases, a boot disk is configured using a 512e drive.

NOTES

For more detailed information on backup failures and performance issues see Unitrends KB 5062 - Backup Failures and Performance Issues

Have more questions?

Contact us

Was this article helpful?
0 out of 0 found this helpful

Provide feedback for the Documentation team!

Browse this section