SUMMARY
Legacy verify fails when post-backup script is used causing errors.
ISSUE
When using the legacy "Enterprise" scheduler to issue post-backup verifies on platforms that require them, combining that process with a post-backup script may lead to verify failures.
RESOLUTION
- Ensure the post-backup script completes in 10 minutes or less.
- For conditions where that cannot be reliably done, use either:
- Inline verify (Windows and Linux as well as some other select platforms) -OR-
- Remove the verify option
- Ensure the errors are eliminated.
- For conditions where that cannot be reliably done, use either:
CAUSE
Verify must begin within 10 minutes of backup completion. In cases where it cannot, the return communication channel to the appliance for that backup will become reset. Some post-backup scripts may take longer than 10 minutes to complete and may impact the ability of the verify to start in a reasonable time. Where possible always use inline verify on supported clients as it is not only more reliable, but, it also ensures every file backed up is verified. When using post-process verify, many files will change after or during backup and cannot be verified after at all and will be skipped in that process. Inline verify is also faster and does not use a secondary queued job. All Windows clients 2003+ and most Linux systems support inline verify. for clients that do not, including Novel, AIX, AS400, and others, post process and verify may conflict in some cases. This will not fail the backup job with it can fail the verify resulting in false negative error reporting.