Modules
Sign in
Get Help

Error You cannot save settings with SSO Enabled without an SSO Certificate Uploaded

Issue

You may receive the "Error: You cannot save settings with SSO Enabled without an SSO Certificate Uploaded"

1.Fill in the following information for your AuthAnvil SSO server:

2.Issuer: (This is found in AuthAnvil Manager > Single Sign On > Server Settings tab. Copy the Token Issuer Name)

•Identity Provider Login URL: http(s)://<your2FAserver.com>/SSO/logon.aspx

•Identity Provider Logout URL: http(s)://<your2FAserver.com>/SSO/authorizedapps.aspx

3.Click “Import New SSO Certificate” and upload the certificate taken from Step #4 in the SSO application configuration above. Click Import Certificate

 

Cause

If you double click the "install" button it will create 2 certificates. We are aware of the issue and working on a resolution at this time.

 

Resolution

  1. Open the DB > dbo.CertificateTableSSO
  2. Disable the trigger
  3. Delete the certificates in the table
  4. Enable the trigger

Follow-up - Perform steps in  steps "Issue" and ensure not to double-click the install button

 

Affects

All versions of AAPS 2.0 SSO 4.0

Questions?

If you have any questions or need some help, we would be happy to assist. Open a case at help.scorpionsoft.com or send an email to support@scorpionsoft.com.

Have more questions?

Contact us

Was this article helpful?
0 out of 0 found this helpful

Provide feedback for the Documentation team!

Browse this section