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Error "Internet connection failed, please check your Internet settings." When activating BlackBerry SoftToken

Issue

When attempting to activate your SoftToken on a BlackBerry that is connected to a BES 4.1 SP7 or later or BES Express 5.0 server, the activation fails with the message: "Internet connection failed, please check your Internet settings."

 

Cause

This issue is caused by a problem with the way that the BES handles SSL certificates.

 

Resolution

From RIM KB 20833: On the BlackBerry smartphone, select Options>Security Options>Advanced Security Options>TLS and change the TLS Default from Proxy to Handheld.  This will allow the BlackBerry smartphone to parse the certificate directly, which does not have the problem with the Subject Alternative Name.

 

Affects

AuthAnvil SoftTokens on BlackBerries connected to a BES 4.1 SP7 or later or BES Express 5.0 server.

 

Questions?

If you have any questions or need some help, we would be happy to assist. Open a case at help.scorpionsoft.com or send an email to support@scorpionsoft.com.

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