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Android SoftToken activation gives the error, “Activation failed! Internet connection failed, please check your Internet settings and try again.”

Issue

When activating an AuthAnvil SoftToken on an Android device running Froyo (OS 2.2) the error, “Activation failed! Internet connection failed, please check your Internet settings and try again.” is displayed.

 

Cause

The Certificate Store within the Android OS on the device does not properly recognize the new higher 2048 bit certificate. Because of this, it is incorrectly reporting that the intermediate certificate chain is not trusted even though it is. This causes HTTPS / SSL communication to fail, which is required to activate the SoftToken initially. Regular generation of One-Time Passwords is not affected.

 

Resolution

Google has addressed this in a newer update to the Android OS (2.3). Update the firmware of the Android OS if your carrier offers a newer version. This issue has not occurred on any devices running Gingerbread (2.3) or later.

If your carrier does not have an available update, contact your device manufacturer for an updated certificate package.

 

Affects

Android devices running Android OS 2.2 ("Froyo")

 

Questions?

If you have any questions or need some help, we would be happy to assist. Open a case at help.scorpionsoft.com or send an email to support@scorpionsoft.com.

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