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Invalid Site ID error when logging into AuthAnvil Manager

Issue

When logging into Anvil Manager you get the error "Invalid Site ID" despite using the correct site.

Cause

The default install sets up the connections to use localhost. AuthAnvil was installed in a site not bound to localhost and the web.configs for the services are now invalid.

The other cause for this error is when the Anvil Manager cannot communicate with the SQL server. This may be caused by any of the following conditions:

  1. Incorrect .NET framework configured in the AuthAnvil Virtual Directories.
  2. Do not have network access to the SQL Server.
  3. Do not have Anonymous Access allowed on the AuthAnvil Virtual Directories.
  4. Invalid SAS URL configured in the web.config.
  5. The SAS URL is correct, but is not resolvable through DNS from the AuthAnvil server.
  6. The 'aadbuser' user does not have permissions to connect to the SQL server.
  7. The 'Anvil' database has AutoClose set to "true" and other connections or backup tools are interfering with AuthAnvil database connections.



Resolution

For Cause #1 Change the web.config file settings for both AuthAnvil Manager and the AuthAnvil Admin web services.

Note: You will need to use and elevated (Run as Administrator) Notepad to save the needed changes on Windows Server 2008.

  1. AuthAnvil Manger
    Open the following file with Notepad: C:\Program Files\Scorpion Software\AuthAnvil\AnvilManager\web.config Edit the following section and change the value from http://localhost/ to the FQDN of your AuthAnvil Manager server. You can use the local name if you do not have DNS mapped to this site in IIS. Change both references and save the file.
    <WebSettings><add key="AdminWebReferenceURL" value="http://localhost/AuthAnvilAdmin/Admin.asmx"/> <add key="SASWebReferenceURL" value="http://localhost/AuthAnvilSAS/SAS.asmx"/></WebSettings>
  2. AuthAnvil Admin   Edit the following file: C:\Program Files\Scorpion Software\AuthAnvil\AuthAnvilAdmin\web.config Edit the following section and change the value from http://localhost/ to the FQDN of your AuthAnvil Admin server. You can use the local name if you do not have DNS mapped to this site in IIS. Change both references and save the file. 
    <appSettings> <add key="AuthAnvilSAS" value="http://localhost/AuthAnvilSAS/SAS.asmx"/> <add key="AuthAnvilSecondarySAS" value="http://localhost/AuthAnvilSAS/SAS.asmx" /> <add key="IdleTimeout" value="20"/> </appSettings>
  3. Close your web browser and restart the AnvilAppPool in IIS or run an iisreset. 
  4. Launch a new browser and log into Anvil Manager.

For Cause #2

  1. Ensure that ASP.NET 2.0 is installed and configured on each of the AuthAnvil Virtual Directories, and ensure Anonymous Access is defined. 
  2. Make sure that the SQL server is accessible via the network, and use the Web Config Editor (located by default at: C:\Program Files\Scorpion Software\AuthAnvil\Tools\AAWebConfigEditor.exe or C:\Program Files\Scorpion Software\AuthAnvil\AuthAnvilTools\AAWebConfigEditor.exe) to make sure that the correct SAS URL is configured in the AuthAnvil web.config files. 
  3. Make sure that the SAS URL is resolvable from the AuthAnvil Server, check hosts files and DNS entries to ensure that the domain name of the server is resolving to the correct IP address.
  4. Add 'aadbuser' (or your authanvil user) to the SQL server with the 'public' and 'sysadmin' roles, and permissions to access the 'Anvil' database.
  5. In the properties of the Anvil database, select Options and change "Auto Close" to "False".  (Read more about AutoClose at http://support.microsoft.com/kb/917828).


Affects

All versions of AuthAnvil Two-Factor Auth unless otherwise noted.

Note: For AuthAnvil 3.x and later, use the Web Config Editor (located by default at: C:\Program Files\Scorpion Software\AuthAnvil\Tools\AAWebConfigEditor.exe or C:\Program Files\Scorpion Software\AuthAnvil\AuthAnvilTools\AAWebConfigEditor.exe) to make sure that the correct SAS URL is configured in the AuthAnvil web.config files.

 

Questions?

If you have any questions or need some help, we would be happy to assist. Open a case at help.scorpionsoft.com or send an email to support@scorpionsoft.com.

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