New or Native 2FA (Two-Factor Authentication) not working in VSA

PROBLEM

Users not prompted to configure new or native 2FA (Two-Factor Authentication) in VSA even after enabling the user for 2FA enrollment.

CAUSE

If you have used Authanvil 2FA with your VSA in the past you need to completely disable Authanvil 2FA first for the New or Native 2FA to work.

RESOLUTION

1. Login to VSA as a master admin.

2. Navigate to Authanvil > Two Factor Auth > Configure Kaseya Logon

Replace the Authanvil SAS URL to https://localhost/authanvil/sas.asmx

Kaseya Logon Configuration: "Enable" the option "Disable two-factor auth during Kaseya server logons"

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3. Once done save the settings and enable the new/native 2FA for the users from System > Server Management > Logon Policy. During the next login, users will get the option to scan the QR code and enroll for the new 2FA.

NOTE: If the still persists even after following the above steps, please create a support ticket. 

 

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