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BMS HR Employees | Error! Cannot add external roles to internal users

Problem

When attempting to mark an employee as "Inactive", you get this error message:

intenral.jpg

Cause

After BMS 4.0.9, you cannot assign External Security Roles to Internal Employees. If a user was created before this patch, marking them "Inactive" would result in this error message.

Resolution

Make the changes mentioned below for the Employee you wish to mark "Inactive":

  1. Via HR > Employees, select the user in question
  2. Set External to "No", and Status to "Inactive"
  3. Go to Security Roles and un-check External Assigned Roles 
  4. Save these changes to the Employee record - this should free up a license and mark the employee as "Inactive".

 

Applies to: BMS 4.0.9 and newer.

 

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