PROBLEM
Upon attempting to export a mailbox to PST you are presented with the following error when reviewing the failure log.
Problems processing Mailbox Error in IMAPISession::OpenMsgStore: MAPI_E_LOGON_FAILED
Make sure your code runs under the Windows user identity that has MAPI profiles.
When running in a service (including ASP under IIS), set your code to run under
the Windows user account that has MAPI profiles.
When connecting to an Exchange Server, you can also use RDOSession.LogonExchangeMailbox
which does not require an existing profile.
ulVersion: 0
Error: The information store could not be opened.
CAUSE
The mailbox is not found in the global address book and instead is marked as hidden.
RESOLUTION
Please check if the Mailbox has the "Hide from Address Lists/Book" checked. If checked, remove this check and export again. If the Mailbox was hidden and re-added to the Global Address List give it at least 24 hours to ensure that at least one address book generation has happened.
APPLIES TO
Office 365