Security Announcement

If I try to run the installer for 5.0.0.66 it only gives me the option to uninstall. Should we upgrade to 5.0.0.66?