Follow

Traverse WebApp Compatibility

Question

 

What internet browsers are compatible with the Traverse webapp?

 

Answer

 

Currently, the Traverse webapp is compatible with Google Chrome, Mozilla Firefox, Safari, Opera and Internet Explorer 9. Java is required to view the Rich UI of the webapp.

Traverse IS NOT compatible with Internet Explorer 10 or Internet Explorer 11.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

0 Comments

Article is closed for comments.