Follow

What Pre-requisites are Needed for Installation?

Question:

What Pre-requisites are Needed for Installation?

Answer:

Linux Installations
Some 64-bit Linux host operating systems don't install 32-bit compatibility libraries by default. Traverse runs on 64-bit systems, but needs the 32-bit compatibility libraries installed. The name of the 32-bit compatibility package varies across Linux distributions. See your distribution's documentation or Web site to determine the 32-bit compatibility package for your distribution

Perl version 5.8 or above (should be included by default) is required. Traverse also requires three specific libraries in addition to the Traverse installer files:

libXp.so.6
libstdc++.so.5
libstdc++-libc6.2-2.so.3
The required RPMs to install for these libraries changes depending on which version of RedHat Enterprise/CentOS is in use. To determine the correct RPM for your platform, you can use the "rpm" command:

Code:
rpm -q --whatprovides $filename


Where $filename is the library, e.g. libXp.so.6. Example session on CentOS 5:

Code:
[root@host ~]# rpm -q --whatprovides libXp.so.6
libXp-1.0.0-8.1.el5


Generally the required packages are compat-libstdc++-33, compat-libstdc++-296, and for libXp.so it may be either libXp, or xorg-x11-deprecated-libs, depending on the OS version.

Windows Installations
On Windows, Traverse requires no pre-requisites and will install all needed packages and files from the Traverse installer.

Solaris Installations
Default Solaris installations include all needed libraries, and any other required packages/files are provided as part of the Traverse installer. Perl version 5.8 or above is also required.

See the Traverse User Guide, Software Requirements for Unix/Linux Platforms for additional details.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

0 Comments

Article is closed for comments.