Follow

KNM Record manager will not start

PROBLEM
The KNM Record Manager will not start.
When you check c:\kaseya\knm\logs\debug.log, you see the message
(3120) Failed to (re)open event queue,  (-1072824317)

When checking the Message queues -> Outgoing queues, you see a lot of errors about queues not existing

queue1.png

 

queue2.png

CAUSE
Your computer name is longer than 15 characters.
MSMQ uses the NetBIOS name to create the queues for backwards compatibility.
KNM will use the Windows computer name, rather than the NetBIOS name.
This results in KNM trying to query a queue name that does not exist, for example.

Computer Name: MY-KASEYA-SERVER-WIN2012
NetBIOS Name: MY-KASEYA-SERVE

When an MSMSQ queue is created the NetBIOS name is used, so we get

MY-KASEYA-SERVE\Private$\Agent

However, when kaseya sends a query to MSMQ it uses the Computer Name, so it queries

MY-KASEYA-SERVER-WIN2012\Private$\Agent

which is not a valid queue name.


WORKAROUND / RESOLUTION
This is a known limitation of MSMQ and the only solution is to change the Computer Name to a name with less than 16 characters (0 - 15)
Once the computer name is changed and the server is rebooted, the problem will go away with no further configuration settings required.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

0 Comments

Article is closed for comments.