Problem
Technicians are not able to view the assigned tickets in ticketing tab , some tickets are missing
Cause
Tickets that are missing from the User/Technician list are associated from the group that is not assigned to user's scope.
Solution
Check the Scope assigned to user , ensure that the associated group is assigned to this scope
Navigate to System > Users> Scope > select Scope > select Organization/ Group tab , to add
the group .