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Newly deployed agents are not able to check-in on R8 servers

PROBLEM:
You have upgraded to R8 and find that any new agent installs are not working.
The installer runs on the endpoint and completes without issue, however in the web interface, you only see a template (Orange Square icon), or in some cases nothing at all.

CAUSE:
The agent installer that you are using is copying the settings from another machine. During the initial install of the agent on a new machine, this copy part is failing

SOLUTION / WORKAROUND:
1. Go to the agent tab -> deploy agent page
2. Click the "notepad" icon on the left of the agent installer that you are using, to edit the install package
3. Click Next. On Step 4 - the copy settings step, select "Do Not Copy Settings"
4. Next your way to the end and save the package

You can now use this installer to install agents. This will be a default agent, and will not copy the settings any longer. But the settings can be copied after the install completes.

5. Go to the Agent tab -> Copy Settings page.
6. Select the agent settings that you want to copy at the top of the page
7. Select the agents that you have just installed (which only have the default settings), and click "Copy".

ADDITIONAL INFORMATION:
Kaseya are aware of this issue and this article will be updated with further news.
(SVE-292)

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9 Comments

  • 0
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    Servicedesk Aspect ICT

    Well, it works for us, I'm happy to say - at least in a first test with a previously installed agent, so not a clean install (but we are going to do that next).

    We happen to be looking at Policy Management and that seems to be a lot better than the last time we looked at it.
    We aim to put the copy settings step in a policy for all new agents, that should be a bit more than a workaround, that should be feasible.

    We could just keep it like that so we don;t have to wait for a final fix.... (just a small matter of changing about 150 packages)....

     

    Thanks John!

    Eric.

     

  • 0
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    Dan Stanford

    John, thanks for calling that in.

    Kaseya, please get this resolved. We grow when we deploy new agents and everyone likes growth.

  • 0
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    Tim Reis

    Doesn't work here, 3 different KServers, new agents still can't check-in even with the Default Install agent.

  • 0
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    Harold Eggens

    Doesn't work here either, new agents still can't check-in even with the Default Install agent. Please get this resolved quickly

  • 0
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    Travis

    doesn't work... I wish Kaseya would quit breaking stuff that worked fine before...

    but they cant even seem to fix the things they work for MONTHS on trying to fix... instead they break something else.

    CMON GUYS!...

  • 0
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    Tim Reis

    The entire check-in component is damaged. The fixes they've made recently have opened up other bugs that no one has been responsive on. After patch 8.0.11 here's what I've found.

    Upon new agent check-in, custom settings still don't apply. They provided me a temporary fix for that which hasn't been released yet.

    After removing an agent off a machine and reinstalling it, it will reuse the old agent on the Kserver unless it was removed as well. (This is improper and the system has never functioned this way) The settings applied to that old agent will automatically apply the the new agent which is dangerous as well.

    If two agents check-in with the same name the 2nd is added with a -1 or -2 at the end which is normal, however any machine with the same name, the custom settings fail to apply.

  • 0
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    Nick Nichols

    Is there an update on this ? I cant add new clients if I cant install agents ?

  • 0
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    Dan Stanford

    The latest patch for R8 fixes the issue.

  • 0
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    Helpdesk

    This issue has returned for us.

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