Follow

KSBR - Profile Apply Error - "An Unknown Error has occurred"

Problem

Kaseya System Backup and Recovery (KSBR) logs this error when trying to apply a KSBR profile :-

Apply Error - "An Unknown Error has occurred"

 

And from the KBR Manager logs (located under the working directory of the KSBR client) it shows the following error :-
CoCreateInstanceFailed : HResult error: 0x80040154
Error message: Class not registered

Cause

A version of ShadowProtect installed on the machine is not supported by Kaseya

 

Resolution

1) Check the ShadowProtect Console on the machine to see what version is running - Kaseya only supports  v5.1.5 or lower
2) If the machine has a later version installed, you will need to uninstall this version and reinstall manually
To manually install -
a) Retrieve the install file from StorageCraft only if you are managing your machines outside of Kaseya, i.e. through the StorageCraft website.
b) If version 5.1.5 is not available from StorageCraft, browse to the following directory on your Kserver - C:\Kaseya\WebPages\ManagedFiles\VSAHiddenFiles\KBR - and locate the ShadowProtectSetup.exe file (this file will also show the version number).
c) Copy this file over to the machine and run it. Input the serial number from StorageCraft, and Apply the KSBR Profile.

Applies To

Kaseya System Backup and Recovery (KSBR)

R8, VSA 7.0, VSA 6.5

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

0 Comments

Article is closed for comments.