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9.2 KAV and 9.3 "Classic" KAV - end users being prompted to install Kaspersky update

Problem

Kaspersky engine on endpoints is prompting user to update to new version. The problem will occur in the following environments: -

  • VSA is on R9.2 or earlier, or VSA is on R9.3 and endpoints are managed by the "Classic" Antivirus module (new Antivirus module on R9.3 is not affected)
  • Kaspersky engine is on v10.2.4.674 or earlier

If the AV profile is configured to show Kaspersky icon in the task bar, the end user will see a warning status there, and when they click on the icon they will see prompt shown below.

 

update_prompt.png

 

Cause

Kaspersky released a new version of the engine which was made available using their update engine. Although it is possible to configure Kaspersky not to download application updates, this configuration cannot be modified by "Classic" KAV code due to limitations in the API used by that product.

Resolution

The underlying problem is addressed in the new Antivirus module in R9.3, where Kaspersky is configured not to install application updates.

R9.3 Classic Antivirus

The update is not mandatory except for endpoints running Windows 10 Anniversary Edition, but is supported by Kaseya code so long as VSA has the latest patch updates. We do not expect any negative impact if a user runs the update.

R9.2 Antivirus

The update will be supported by Kaseya code after patch 9.2.0.22 is released. If a user runs the update before VSA has the patch, there may be issues with management of the endpoint but the computer will still be protected by the Kaspersky engine. The current ETA for the patch is week beginning Sept 19th. 

 

Is there any way to prevent users from seeing the notification?

Whilst it is not possible to prevent Kaspersky installations managed by Classic KAV from displaying this notification, it can be hidden from the end user by configuring the profile not to display the taskbar icon (see below).

profile.png

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