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KRC is unstable when Java 8 installed on Kaseya server

Problem

  • users of Kasaya Remote Control (KRC) experience frequent unexpected disconnections
  • underlying network connections (viewer to Kaseya server, agent to Kaseya server, viewer to agent) have been tested and found to be stable
  • Java v8 is installed on the Kaseya server

Cause

  • SSL connection error in Java Runtime Environment (JRE)
  • this is related to a documented problem with Java v8 - https://bugs.openjdk.java.net/browse/JDK-8049855

Solution

  • this article will be updated when a solution is available

Workaround

"Downgrade" Java installation on Kaseya server to v7: -

1) go to Windows services manager (services.msc) and stop "Kaseya Edge Services" (NB - this will stop all communication with the Kaseya server including agent check-ins, remote control sessions, access to the web interface)

2) go to Control Panel > Programs > Programs and Features, uninstall Java 8

3) install the latest v7 update, which can be downloaded from here - http://www.java.com/en/download/manual_java7.jsp

 

Applies to

Kaseya VSA - v7.0 and above

Java v8

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