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Error 403 - Unable to start session with the endpoint

PROBLEM

When using Live Connect to connect to an endpoint, an error message is thrown stating: “Error: The request failed with status code: 403.”

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CAUSE

This is a user rights permissions problem that prevents the User Role from accessing KLC from being used. For the new KLC connection to be established, the User Role accessing the KLC endpoint must have the following access rights:

  • Live Connect > Home > Home
  • Audit > Asset > View Assets > View
  • Audit > View Individual Data > Machine Summary (just the page, none of the underlying pages are required)

Depending on features used within Live Connect, some, or all, of the following permissions may also be needed:

Module Permission
Agent Manage Agents
Agent Agent Logs
Agent Procedures Schedule Agent Procedure
Agent Procedures Get File
Agent Procedures Agent Procedure Status
Agent Procedures Schedule / Create
Audit Installed Applications
Audit Software Licenses
Audit Accounts
Audit Groups
Audit Members
Patch Management Scan Machine
Patch Management Machine History
Patch Management Machine Update
Patch Management Patch Status
Quick View Edit Procedure List
Quick View Change Settings
System Machine Groups

 

WORKAROUND / RESOLUTION

Option 1

  • Add the permissions listed above to User Role permissions for affected users

Option 2

  • The VSA system can be configured to turn off the new Live Connect and use “Classic” Live Connect, for which required permissions are the same as for VSA R9.2 and earlier. Please note: This configuration will apply to ALL users. After making this change, users will need to log out and then log in again.

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Reference: #134719 / RC-1770 and #135817 / RC-1891

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