Follow

Installation of KLC plug-ins on Chrome v23 or higher fails with "ERROR 1071"

SYMPTOM

Installation of KLC plug-ins on Chrome v23 or higher fails with the error shown below.

 

 

CAUSE

Google is phasing out the manifest format used in Live Connect on Kaseya v6.2. Chrome 23 still officially supports the format but Plugin Manager invokes Chrome to build a .crx container, and this process causes the above error.

 

SOLUTION

The issue is resolved in Kaseya VSA v6.3 software. The below workarounds can be used for Kaseya VSA v6.2 software.

------


WORKAROUND 1

--------

ON-PREMISE CUSTOMERS

An "out-of-band" VSA server patch to address the issue can be downloaded from here.

Note - After downloading this to your VSA App machine, right click the file and choose the Properties dialog. In the General tab, if it is showing as blocked, click unblock.

-----

First make sure you back up the existing files to another location outside of the Kaseya install directory.

Then proceed as follows to apply the patch to your kserver: - 

1) extract manifest.json file to /Kaseya/WebPages/KLC/resources/win/32/netscape/plugin/

2) extract the 3 files in the "PluginManager" directory to /Kaseya/WebPages/inc/PluginManager/

 

To test in Chrome proceed as follows: -

1) Go to Tools > Extensions and remove "Live Connect Plug-ins" and "Plug-in Manager"

2) Restart Chrome

3) Attempt to use KLC again - it should successfully install the plug-ins

--------

CLOUD CUSTOMERS

The cloud platform is planned for upgrades starting mid-December and an eventual set of upgrades will include the fixes for this. Until then, use a different web browser (Internet Explorer or Firefox), or install an older version of Chrome (v22 or lower). Once the plug-ins have been successfully installed, Chrome can be updated to v23 again.

------------

------------

WORKAROUND 2

----

CLOUD & ON-PREMISE CUSTOMERS

For On-Premise & Cloud customers, you can use a different web browser (Internet Explorer or Firefox), or install an older version of Chrome (v22 or lower). Once the plug-ins have been successfully installed, Chrome can be updated to v23 again.

-------

APPLIES TO

Kaseya VSA (v6.2 and lower)

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

0 Comments

Article is closed for comments.