Integrating BMS & VSA Live Connect: Receiving OAuth Connection Error

PROBLEM

When navigating to Admin > Service Desk > RMM Integration Settings > Live Connect tab in BMS, the following error is displayed: "Your VSA version does not support an OAuth Connection. VSA v9.X or later is required."

 

CAUSE

The VSA is likely not exposed via SSL with a valid certificate, which is dictated by the VSA API and a prerequisite.

 

RESOLUTION

Two things must be done:

  1. Install a valid SSL certificate on the VSA server.
  2. Use a URL with https:// (not http://) under Admin > Service Desk > RMM Integration Settings > General Settings > Server Address.

 

The prerequisite instructions can be found here:

  • http://help.kaseya.com/webhelp/EN/BMS/#38043.htm

For instructions on installing an SSL certificate, please see here:

  • https://helpdesk.kaseya.com/hc/en-gb/articles/229026408

Information on purchasing an SSL certificate can be found here:

  • https://helpdesk.kaseya.com/hc/en-gb/articles/229026388-Purchasing-an-SSL-Certificate
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